SAP CCMS nagio plugin configuration

PiCo pico at cocco.biz
Tue May 6 15:00:00 MET DST 2008


Hi!
I'm trying to use the CCMS nagios plugin to monitor some SAP system.

I'm having prblem because seems that something missing in the configuration.
This is my situation:

1. nagios (2.9) is installed and operative
2. nagios plugin (1.4.9) is installed and operative.
3. nagios CCMS plugin (0.7.3) is installed on plugin directory 
(/usr/local/nagios/libexec)
4. nagios CCMS plugin config file is located on 
/usr/local/nagios/etc/sapmon/ (but I have tryed also with /etc/sapmon/)
5. example of agent.cfg:
[TEMPLATE_workload]
DESCRIPTION="Load Average"
MONI_SET_NAME="SAP CCMS Admin Workplace"
MONI_NAME="Operating System"
MAX_TREE_DEPTH=0
PATTERN_0="*\*\CPU\5minLoadAverage"

6. Example of login.cfg:
[LOGIN_REM]
LOGIN=-d REM -u nagios -p nagios -c 300 -h 10.4.5.107 -s 00

Problem:
If I run (from /usr/local/nagios/libexec/)
./check_sap_cons workload REM
I receive this error:
Could not initialize INI-File

What's missing ??


-- 
                                               ,,,
                                             /'^'\
                                            ( o o )
----------------------------------------oOOO--(_)--OOOo------
      Pierfrancesco Cocco
      EMail: pico at cocco.biz
      Web: www.cocco.biz
      SkypeID: cocco.biz
      Tel.: +39 335 1234 475
      Fax.: +39 06 233 2401 88           .oooO
                                         (   )   Oooo.
------------------------------------------\ (----(   )-------
                                           \_)    ) /
                                                 (_/



More information about the linux.general mailing list