RZ20 and Nagios

Werner Flamme werner.flamme at ufz.de
Thu Mar 6 10:51:30 MET 2008


Marco Wiese   [06.03.2008 09:53]:
> Werner Flamme <werner.flamme at ufz.de> schrieb am 05.03.2008 15:53:00:
>  
>> Hi,
>>
>> we use nagios (check_sap_cons) to query some data from the CCMS. That's
>> working fine (thanks to this mailing list ;-)) - Sol Man 4.0, NW 
> 2004s/7.0.
>> Now we try to monitor our ERP systems insinde RZ20. The monitors are
>> defined and show up in RZ20. But I cannot read them with the nagios 
> plugin.
>> Are there special requirements for the indicators inside SAP? Or is it
>> impossible to read values from other systems?
>>
>> Regards,
>> Werner
>>
> 
> Hi Werner,
> 
> yes, it's possible. You can monitor all entries in RZ20 with nagios-ccms 
> plugin. I figured out, that you have to set your monitor templates in 
> /etc/sapmon/agent.cfg with numbers, not with characters, such as 
> "TEMPLATE_15" instead of "TEMPLATE_JOBS" (just an example).
> 
> So, here is an example of my agent.cfg, which works for me:
> 
> [TEMPLATE_15]
> DESCRIPTION="Enqueue Utilisation"
> MONI_SET_NAME=SAP CCMS Technical Expert Monitors
> MONI_NAME="All Monitoring Contexts"
> MAX_TREE_DEPTH=0
> PATTERN_0="QS0\Enqueue\Enqueue Server\Granule Entries Actual Utilisation"
> 
> Just have a look at the pattern above. Modify it for your needs and give 
> it a try. Compare the entries with the entries in your RZ20 (-> SAP CCMS 
> Technical Expert Monitors -> All Monitoring Contexts -> Enqueue -> Enqueue 
> Server -> Granule Entries Actual Utilisation).
> 
> Let me know, if it works... :-)
> 

Marco,

thanks, but it does not help.

We have a monitor collection in RZ20 named "Andere SAP Systeme" with the
SAPSID as identifier underneath.

A working config is:
[TEMPLATE_systemfull]
MONI_SET_NAME = "SAP CCMS Technical Expert Monitors"
MONI_NAME     = "All Contexts on Local Application Server"
PATTERN_0     = "*\SYSTEM\Used space"

[TEMPLATE_gimmeall]
MONI_SET_NAME = "SAP CCMS Technical Expert Monitors"
MONI_NAME     = "All Contexts on Local Application Server"
PATTERN_0     = "*"

And the following samples do not work:
[TEMPLATE_815]
MONI_SET_NAME = "Andere SAP Systeme"
MONI_NAME     = "SOM"
PATTERN_0     = "*"

[TEMPLATE_4711]
MONI_SET_NAME = "Andere SAP Systeme"
MONI_NAME     = "SOM"
PATTERN_0     = "sapsom_SOM_00\R3Syslog\SyslogFreq"

It does not matter what we give as MONI_NAME ord pattern, we do not see
anything from "Andere SAP Systeme" :-(

*headbang* to correct myself: just tested it with another SID as
MONI_NAME - and it works! When using numbers, not when using letters.
With [TEMPLATE_alluft] it still is "No information gathered! System up?"

Thank you! Now we go to look for the slack joint ;-)

Regards,
Werner

-- 
Werner Flamme, Abt. WKDV
Helmholtz-Zentrum für Umweltforschung GmbH - UFZ
Permoserstr. 15 - 04318 Leipzig
Tel.: (0341) 235-1921 - Fax (0341) 235-451921
http://www.ufz.de - eMail: werner.flamme at ufz.de


More information about the linux.general mailing list