Installation problem on Suse 10.2

Peter Küppers peter-mailbox at web.de
Sat Aug 18 08:51:12 MET DST 2007


Hello,

since I can't find my post to the forum anymore, I post my solution for the 
NW04 testdrive SR1 WAS 6.40 and MaxDB 7.5 for Linux Kernel 2.6 here again:

>>>
Problem:
> I installed SAP NW04 testdrive SR1 WAS 6.40 and MaxDB 7.5 on openSUSE 10.2
> with Linux Kernel 2.6. During the installation, I've found out, that some
> settings from the install.sh script don't work anymore:
>
> 1.) /proc/sys/vm/heap-stack-gap doesn't exist anymore in openSUSE
> 10.2, /etc/sysctl.conf is not updated with vm.heap-stack-gap=256
>
> 2.) setenv LD_ASSUME_KERNEL don't work anymore in openSUSE 10.2 (see
> https://bugzilla.novell.com/show_bug.cgi?id=144935), setenv
> LD_ASSUME_KERNEL 2.4.1 has to be uncommented in /sapmnt/home/nw4adm/.cshrc
>
> When I try to start the WAS with user nw4adm and command startsap nw4host,
> I get the error 'Database start failed'.
> startdb.log says:
> -24994,ERR_RTE: runtime environment error
> 1,Check knldiag! Kernel died before reaching ADMIN state
>
> I found out from SAP note 788272 and 958253, that most likely the MaxDB and
> the SAP Kernel from the Testdrive don't work with Linux Kernel 2.6
> (incompatible because Kernel 2.6 uses Linux Posix Thread Implementation
> NPTL, so LD_ASSUME_KERNEL don't work).
> MaxDB 7.5.00 32bit must be greater than build 25
> SAP Kernel must be greater than 6.40
>
Solution:
> The recommended solution is patching the SAP Kernel and MaxDB.
I upgraded the MaxDB database to 7.6 (Build 35) and that solved the problem. 
<<<

Peter

Am Freitag, 17. August 2007 13:26 schrieb Zoltan Sekeres:
> Hallo Harald,
>
> On 8/17/07, Harald Vajkonny <vajkonny at t-online.de> wrote:
> > I just tried to install NW4 testsuite on my Suse 10.2 linux, but the
> > installation quit at the first time because of an entry in /etc/hosts
> > (195.155.155.1 nw4host), which I had included manually before
> > installation. After removing it, rebooting and trying to call install.sh
> > again, I now get the following error message:
>
> Do you try to install the NW04 testdrive which is based on SAP 6.40? The
> quoted error messages point to this.
>
> That version requires ancient LinuxThreads which were replaced by NPTL in
> the runtime libraries by all current distributions.
>
> I'm not too familiar with SUSE distributions but I doubt that openSUSE 10
> for example does support it. Otherwise you might try to install
> LinuxThreads additionally. Or use an dated distribution which still
> supports it.
>
> Und tschuess,
> Zoltan


More information about the linux.general mailing list