AW: AW: mySAP WAS TestDrive installation has failed...

Steve Johnson steve_basis at yahoo.com
Mon Apr 28 02:13:03 MET DST 2003


Hello All,

Is the mysap test drive version prvided by SAP is only
valuable to Red hat 7.1?. I tried to install on 7.2
and finally the SAP/DB instances are starting fine but
i am also geting the same error for niping -t -H
<hostname>.

And also i am unable to connect with guistart. please
advise if this is not compatible, is there any other
help to install any demo versions to learn SAP more.


Please advise. 
Thanks,
Steve
--- Panos Platon Tsapralis <mysapwasonlinux at yahoo.gr>
wrote:
> Dear all,
> 
> The installation of SAP WAS TestDrive on Red Hat 8.0
> still fails, 
> allthough I have modified my hostname to a value
> shorter than eight 
> characters ("panos").
> 
> The symptom is:
> 
> checking RFC destination...
> could not connect SAP instance at host panos with
> system number 18
> see logfile /usr/sap/WAS/DVEBMGS18/work/startrfc.log
> error:%post(sapbasis-6.10.1) scriptlet failed, error
> status 1
> 
> I get this message right after the database gets
> populated with its 
> content. The logfile "startrfc.log" says:
> 
> RFC Call/Exception: open
> Group       Error group 102
> Key         RFC_ERROR_COMMUNICATION
> Message     Connect to SAP gateway failed
> Connect_PM  GWHOST=panos, GWSERV=sapgw18,
> ASHOST=panos, SYSNR=18
> 
> LOCATION    CPIC (TCP/IP) on local host
> ERROR       partner not reached (host panos, service
> 3318)
> 
> TIME        Thu Apr 10 13:12:51 2003
> RELEASE     610
> COMPONENT   NI (network interface)
> VERSION     35
> RC          -10
> MODULE      niuxi.c
> LINE        1001
> DETAIL      NiPConnect
> SYSTEM CALL connect
> ERRNO       111
> ERRNO TEXT  Connection refused
> COUNTER     1
> 
> I have also observed the following:
> 
> Right after the failure, the usual 'ms', 'co',
> 'es'-type processes 
> appear in 'ps -ef', but no 'dw', and, if I issue
> 'stopsap/startsap' 
> commands (they appear to execute normally), a line
> gets written into the 
> file 'startsap_...log', that says that the 'dw'-type
> child process has 
> terminated with status 0.
> 
> I am attaching the 'startsap...log' file, as a
> reference for those who 
> might want to take a look.
> 
> Any ideas on how to fix this, anybody?
> 
> Regards,
> Panos.
> 
> SAP DB wrote:
> 
> >Yeah, it sounds strange.
> >But there is a SAPNOTE about it.
> >I have no access to the OSS so I could not provide
> you
> >with the right number of this SAPNOTE.
> >
> >To resume the installation after changing the
> hostname will not help
> >because the installation logfile has the old name
> (as the hostname) in it
> >and the installation program (r3setup) will try
> >to connect host via the no more existing hostname
> and will fail.
> >
> >And it is the best thing to remove all
> >by erasing the rpm-packages
> >mentioned in o) of the file "install" on the first
> CD.
> >
> >
> >
> >Good luck.
> >
> >Uwe
> >
> >
> >
> >-----Ursprungliche Nachricht-----
> >Von: linux.general-admin at listserv.sap.com
> >[mailto:linux.general-admin at listserv.sap.com]Im
> Auftrag von Panos Platon
> >Tsapralis
> >Gesendet: Donnerstag, 10. April 2003 13:09
> >An: Uwe Wortmann
> >Cc: linux.general
> >Betreff: Re: AW: mySAP WAS TestDrive installation
> has failed...
> >
> >
> >Uwe Wortmann wrote:
> >
> >  
> >
> >>Hello!
> >>
> >>There are three possible faults:
> >>
> >>1. the hostname panosplaton is too long (you must
> not use more than eight
> >>characters)
> >>2. the hostname panosplaton is not mentioned in
> /etc/hosts
> >>3. there is no entry or more than one in
> /etc/services for the port 3318:
> >>it should be: sapgw18  3318/tcp
> >>
> >>The first fault is the most possible to produce
> the described error.
> >>
> >>I hope this will help you.
> >>
> >>Regards
> >>
> >>Uwe Wortmann
> >>
> >>dq-edv systemtechnik
> >>Manderscheidtstr. 30
> >>45141 Essen
> >>
> >>Telefon: 0201-2894912
> >>Telefax: 0201-2894914
> >>E-mail : uw at dq-edv.de
> >>
> >>
> >>-----Ursprungliche Nachricht-----
> >>Von: linux.general-admin at listserv.sap.com
> >>[mailto:linux.general-admin at listserv.sap.com]Im
> Auftrag von Panos Platon
> >>Tsapralis
> >>Gesendet: Donnerstag, 10. April 2003 12:32
> >>An: linux.general
> >>Betreff: mySAP WAS TestDrive installation has
> failed...
> >>
> >>
> >>My installation of mySAP Technology TestDrive (SAP
> Web Application
> >>Server on Linux) has failed while installing the
> "sapbasis" RPM package,
> >>returning the following message:
> >>
> >>checking RFC destination...
> >>could not connect SAP instance at host panosplaton
> with system number 18
> >>see logfile
> /usr/sap/WAS/DVEBMGS18/work/startrfc.log
> >>error:%post(sapbasis-6.10.1) scriptlet failed,
> error status 1
> >>
> >>I am attaching the logfile, mentioned above, to
> this message.
> >>
> >>Can you, please, help me resolve this? I have
> thoroughlly applied all
> >>instructions of the installation document, so, I
> can't understand what I
> >>am missing or doing wrong...
> >>
> >>Regards,
> >>Panos Platon Tsapralis.
> >>
> >>
> >>
> >>    
> >>
> >Uwe, thanks for the reply. However, the host name
> being longer than 8
> >characters sounds strange to me ('localhost' is
> also longer than 8
> >chars). Anyway, I am giving it a try by replacing
> my host name with a
> >shorter one. Do you know whether there is any way
> to resume the
> >installation from the point where it has failed (or
> do I have to remove
> >& reinstall the various components)?
> >
> >Regs,
> >Panos.
> >
> >
> >_______________________________________________
> >linux.general mailing list
> 
=== message truncated ===> Trace of system
startup/check of SAP System WAS on
> Thu Apr 10 18:10:40 EEST 2003
> 
> 
> Called command: /usr/sap/WAS/SYS/exe/run/startsap 
> 
> Starting SAP-Collector Daemon 
> ------------------------------
>  saposcol on host panos started
> 
> Checking WAS Database
> ------------------------------
>  Database is not available via
> /usr/sap/WAS/SYS/exe/run/R3trans -d -w
>  Running /usr/sap/WAS/SYS/exe/run/startdb 
>  /usr/sap/WAS/SYS/exe/run/startdb completed
> successfully 
> 
> Checking WAS Database
> ------------------------------
>  Database is running
> 
> Starting SAP Instance 
> ------------------------------
> 
> SAP-R/3-Startup Program V1.7 (92/10/21)
> ---------------------------------------
> 
> Starting at 2003/04/10 18:10:51
> Startup Profile:
> "/usr/sap/WAS/SYS/profile/START_DVEBMGS18_panos"
> 
> Execute Pre-Startup Commands
> ----------------------------
> (14135) Local: /usr/sap/WAS/SYS/exe/run/sapmscsa -n
> pf=/usr/sap/WAS/SYS/profile/WAS_DVEBMGS18_panos
> /usr/sap/WAS/SYS/exe/run/sapmscsa: SCSA is attached
> and useable.
> /usr/sap/WAS/SYS/exe/run/sapmscsa: finished.
> (14135) Local: rm -f ms.sapWAS_DVEBMGS18
> (14135) Local: ln -s -f
> /usr/sap/WAS/SYS/exe/run/msg_server
> ms.sapWAS_DVEBMGS18
> (14135) Local: rm -f dw.sapWAS_DVEBMGS18
> (14135) Local: ln -s -f
> /usr/sap/WAS/SYS/exe/run/disp+work
> dw.sapWAS_DVEBMGS18
> (14135) Local: rm -f co.sapWAS_DVEBMGS18
> (14135) Local: ln -s -f
> /usr/sap/WAS/SYS/exe/run/rslgcoll
> co.sapWAS_DVEBMGS18
> (14135) Local: rm -f se.sapWAS_DVEBMGS18
> (14135) Local: ln -s -f
> /usr/sap/WAS/SYS/exe/run/rslgsend
> se.sapWAS_DVEBMGS18
> 
> Starting Programs
> -----------------
> (14145) Starting: local ms.sapWAS_DVEBMGS18
> pf=/usr/sap/WAS/SYS/profile/WAS_DVEBMGS18_panos
> (14146) Starting: local dw.sapWAS_DVEBMGS18
> pf=/usr/sap/WAS/SYS/profile/WAS_DVEBMGS18_panos
> (14147) Starting: local co.sapWAS_DVEBMGS18 -F
> pf=/usr/sap/WAS/SYS/profile/WAS_DVEBMGS18_panos
> (14148) Starting: local se.sapWAS_DVEBMGS18 -F
> pf=/usr/sap/WAS/SYS/profile/WAS_DVEBMGS18_panos
> (14135) Waiting for Child Processes to terminate.
>  Instance on host panos started
> (14135) **** 2003/04/10 18:11:37 Child 14146
> terminated with Status 0 . ****
> 


__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com



More information about the linux.general mailing list