Red Hat Linux 7.3 and SAP

Frank Schilling frank.schilling at sap.com
Mon Sep 23 10:01:38 MET DST 2002


Hello David,

why not to use WAS 6.10 test-drive instead of SAP Basis Release 4.6?
At least I was able to install considering the following hints:

The WAS test-drive was developed for Red Hat Linux 7.1. 
Unfortunately Red Hat Linux 7.3 won't work without problems.
However, you can resume with the installation if you go
step by step through the following points:

1) libdb-3.1: 
   Install "db3x-3.2.9-4.i386.rpm", which can be found
   on the second installation CD of your Red Hat distribution.

2) libstdc++-libc6.1-2.so.3: 
   Install "sgcc-libstdcxx-2.95.2-SAP2.i386.rpm", which is
   located in the gcc directory of the WAS test-drive CD1. 

3) Now you should repeat the command
   "rpm -ivh sapappsrv-sapdb-6.10-1.i386.rpm"
   and receive the following list of errors:

   error: failed dependencies:
          libcrypto.so.0.9.6 is needed by sapappsrv-sapdb-6.10-1
          libssl.so.0.9.6 is needed by sapappsrv-sapdb-6.10-1 

   Otherwise you have to install all other missing packages first,
   until you have reduced the failed dependencies to the
   expected list.

4) libcrypto.so.0.9.6  and  libssl.so.0.9.6:
   This problem is caused by differences between Red Hat and SuSE
   Linux regarding the package "openssl-0.9.6*". 
   Make sure that the package "openssl-0.9.6*" is installed:

   rpm -qa | grep openssl

5) If the points 1) to 4) are fulfilled you can ignore the
   error message and resume via

   rpm -ivh --nodeps sapappsrv-sapdb-6.10-1.i386.rpm"    

Greetings from SAP LinuxLab - Frank Schilling
-- 
 ________________________________
| Frank Schilling______________________________________________    
| realTech system consulting GmbH   frank.schilling at realtech.de   
| zz. SAP AG                        
| LinuxLab                                                



"Elboth, David" wrote:
> 
> > Hello,
> >
> I have just installed Red Hat Linux version 7.3 on my Laptop (DELL P. with 512 MB RAM and 50 GB of disk). I would like to install SAP basis Release 4.6 with SAP DB. Can I use the glibc library which is included with this version of Red Hat Linux. If not when will SAP support Red Hat Linux 7.3.
> 
> Kind regards
> David Elboth
> 
> _______________________________________________
> linux.general mailing list
> linux.general at listserv.sap.com
> http://listserv.sap.com/mailman/listinfo/linux.general



More information about the linux.general mailing list